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Outline

• Using objects in VBA
• Application-embedded scripting
• Classes and properties
• Visual programming and callbacks
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Using Objects

Dim a1 As Apple       ' declare variables a1 and a2
Dim a2 As Apple       ' of class Apple
Set a1 = New Apple    ' allocate new objects, assign
Set a2 = New Apple    ' references (need "Set" keyword)
a1.color = "green"    ' set property, differently
a2.color = "red"      ' for a1 and a2
a1.prepare("slice")   ' call method, passing
a2.prepare("squeeze") ' string parameter

VBA

© Martin Hirzel G22.3033-002 NYU 5/29/2008 4

Classes and Objects
Concepts

pluck()
prepare()

color
weight

Apple color = “green”
weight = 150

a1 : Apple

color = “red”
weight = 150

a2 : Apple

class

name

properties

methods

instance name : class name

property values

objects

members
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VBA

With ActiveWindow.Selection.SlideRange.Shapes.Title
  .Flip (msoFlipVertical) ' call method
  .Rotation = 15          ' assign to property
End With

Abbreviated Member Access

Abbreviated Member Access
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Properties vs. Fields
• Both: dot notation look&feel

– Writable: a1.color = "red”
– Readable: Debug.print a1.color

• Properties only: associated behavior
– E.g., update graphical representation

• Properties only: may be indexed, like arrays
– cake.ingredient("topping") = a1

• Other languages with properties:
– E.g., PHP, Delphi, C#

Concepts
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Common Uses of Properties
Concepts

Simple (field-like)
• Visual update
• Invariant checking

– Filter illegal values
– Read-only
– Copy on write

• Logging

Indexed (array-like)
• Collections

– Resizable array
– Hash map

• Persistence
– File
– Database
– Cookie
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Collections
VBA

Dim col As Slides
Set col = ActivePresentation.Slides
Dim i As Integer
Debug.Print "for-loop, indexed property access"
For i = 1 To col.Count
  Debug.Print col.Item(i).Name
Next i
Debug.Print "for-loop, default property access"
For i = 1 To col.Count
  Debug.Print col(i).Name
Next i
Dim s As Slide
Debug.Print "for-each loop"
For Each s In col
  Debug.Print s.Name
Next s
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Progressive Disclosure
Soap-box

• We only looked at how to use classes,
but not how to define classes
– That’s sufficient for most VBA tasks!

• Language design encourages this:
– Learn small subset of language to do most

important tasks
– Learn a little more to do a little more

• Progressive disclosure user experience
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Outline

• Using objects in VBA
• Application-embedded scripting
• Classes and properties
• Visual programming and callbacks
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Where Is My Code?
VBA
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Structure of a VBA Application
• Projects

– Files: .ppt, .xls, .doc
– Normal.dot for Word
– Personal Macro

Workbook for Excel
(Window→Unhide)

• Modules
– Regular module
– Class module
– Form with code sheet

• Subroutines
– Function or Sub (Macro)

VBA
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Scopes and Visibility

• Project dependencies
– Visual Basic Editor→Tools→References
– Then, can call across projects:
project.module.subroutine

– Cyclic references are not allowed
• Visibility

– “Instancing” property of class module
– Public/Private modifiers of declarations

VBA
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Powerpoint Object Model
Reference

• The complete object
model is much larger

• See Visual Basic
help in editor

• Also in MSDN library:
→Office development
→Microsoft Office 2003
→Office 2003
→VBA reference
→Powerpoint help
→Object model

Application
    CommandBars
        CommandBar
    DocumentWindows
        Selection
            ShapeRange >
    Presentations
        Presentation >
ActiveWindow
    Selection
        SlideRange
            Shapes
                Shape
ActivePresentation
    Slides
        Slide
            Shapes >
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Object Model

• Object-oriented API
for embedded scripts

• Other examples:
– Object models for

other Microsoft apps
– DOM = document

object model for XML

Concepts

Application
    CommandBars
        CommandBar
    DocumentWindows
        Selection
            ShapeRange >
    Presentations
        Presentation >
ActiveWindow
    Selection
        SlideRange
            Shapes
                Shape
ActivePresentation
    Slides
        Slide
            Shapes >

Top-level
“creatable
objects”

“has-a” /
“contains”
relationship

“>”: more
objects
(not shown)

Gray box:
simple object

White box:
collection
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Outline

• Using objects in VBA
• Application-embedded scripting
• Classes and properties
• Visual programming and callbacks
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Defining Classes
VBA

Public color As String
Public weight As Double

Public Function pluck() As String
  pluck = Me.color & " apple"
End Function

Public Sub prepare(how As String)
  Dim dish As String
  Select Case how
    Case "slice"
      dish = "salad"
    Case "squeeze"
      dish = "juice"
    Case Else
      dish = "dessert"
  End Select
  Debug.Print "yum, " & pluck() & " " & dish
End Sub

pluck()
prepare()

color
weight

Apple

Name property
of class module

Pr
op

er
tie

s
M

et
ho

ds
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Documentation of OO in VBA
• MSDN library

→Development tools and languages
→Visual Studio 6.0
→Visual Basic 6.0
→Product documentation
→Using Visual Basic
→Programmer’s guide
→Part 2: What can you do with Visual Basic
→Programming with objects

Reference
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Defining Properties

• Syntax
– Property Get id([arg*]) … End Property
– Property Let id([arg*,] arg) … End Property
– Property Set id([arg*,] arg) … End Property

• Remarks
– To return value from Get, assign to id
– Let assigns regular value, Set assigns object
– Extra arguments, if any, are for indexing
– Each routine can be Private or Public
– Public variable is just shortcut for routines

VBA
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Inheritance

pluck()
prepare()
peel()

weight
Banana

pluck()
prepare()

weight
color

Apple

pluck()
prepare()

weight
Fruit

Concepts

Superclass/
Base class/
Interface

Implements/
“is a” relationship

Subclasses/
Derived classes

Can add
additional
methods

Can add
additional
properties
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Inheritance in VBA
VBA

Implements Fruit
Public color As String
Private wght As Double
Private Property Let Fruit_weight(ByVal RHS As Double)
  wght = RHS
End Property
Private Property Get Fruit_weight() As Double
  Fruit_weight = wght
End Property
Private Function Fruit_pluck() As String
  Fruit_pluck = color & " apple"
End Function
Private Sub Fruit_prepare(how As String)
  Debug.Print how & “d “ & Fruit_pluck()
End Sub

Public weight As Double
Public Function pluck() As String 'empty routine
End Function
Public Sub prepare(how As String) 'empty routine
End Sub

Class module
“Fruit” (Interface)

Class module
“Apple”
(subclass)

Would be abstract
in other languages

“Implements” in
subclass identifies
superclass

Override private

with mangled name
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Pure Interface Inheritance
• Interface inheritance (in VBA):

– Subclass must provide own implementation
for all methods in superclass

– Can use object of subclass
where object of superclass is expected

• Implementation inheritance (not in VBA):
– Subclass can leave some methods from

superclass unchanged
– Those method implementations are reused

• To reuse code in VBA, must call it by hand

Concepts
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Subtyping Example
VBA

Dim someFruit As Fruit
If … Then
  Set someFruit = New Apple
Else
  Set someFruit = New Banana
End If
' compiler knows that the method exists,
' even if it doesn’t know which version
' will get called
someFruit.prepare("slice")
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Missing OO Features in VBA

• Implementation inheritance
• Constructors

– Can write Class_Initialize() method
– Or write subroutine in separate module to

allocate new instance and initialize it
• Static fields and static methods

⇒ OO features changed in VB.NET

Soap-box
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Outline

• Using objects in VBA
• Application-embedded scripting
• Classes and properties
• Visual programming and callbacks
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VBA

Load frmLemonStar
frmLemonStar.Show
MsgBox "done, number of lines was " & _
  frmLemonStar.txtNumberOfLines.Text
Unload frmLemonStar

Loading is optional Name of module
Display dialog box,
wait for user input,
run event handlers

Unloading is optional

Retrieve user input

Using Dialogs
• Dialog = window to request user input
• User form = module defining dialog
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Hungarian Notation

• Convention: start
identifier with
indication of type

Concepts

Text boxtxt

Labellbl

Option buttonopt

Menumnu
Combo boxcmb

List boxlst

Framefra

User formfrm

Command buttoncmd

Check boxchk
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Dialog Example
VBA
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Drag&Drop Dialog Design

• Right-click on project→Insert→User form
• View→Properties Window

– Change name, caption, maybe width/height
• View→Toolbox

– Drag and drop controls onto user form
– Rename, resize, set initial value
– Set “default” or “cancel” property for buttons

• Right-click on form→Tab order
– Order when user “tabs through” controls

VBA
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Writing Event Handlers
Sub paintLemonStar(nLines As Integer)
  Dim n As Integer, i As Integer
  n = nLines - 1
  For i = 0 To n
    Dim l As Shape
    Set l = ActiveWindow.Selection.SlideRange.Shapes.AddLine( _
      BeginX:=300, BeginY:=200 + i * 100 / n, _
      EndX  :=400, EndY  :=300 - i * 100 / n)
    l.Line.ForeColor.RGB = RGB(i * 255 / n, i * 255 / n, 0)
  Next i
End Sub

Private Sub cmdPaint_Click()
  paintLemonStar CInt(txtNumberOfLines.Text)
  Hide
End Sub

Private Sub cmdCancel_Click()
  End
End Sub

VBA

Retrieve user input

Callbacks with mangled names

Auxiliary subroutine
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Code Sheets

• Right-click→View code
– Just like other modules
– Contains event handlers as well as regular

subroutines
• Double-click on control

– Goes to handler, creating it if necessary
– Caution: handler name not changed automatically

with control name!
• Dynamic dialog: assign properties at runtime

– E.g., Visible=True reveals hidden controls
– UserForm_Initialize sets default, e.g. for list box

VBA
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Call-backs
VBA code Interpreter User

frmLemonStar.Show()
wait for user input

edit text box

click button

cmdPaint_Click()

return from handler

return from “Show”

Concepts
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Common Controls and Events

• Controls:
Label, TextBox, ComboBox, ListBox, CheckBox,
OptionButton, ToggleButton, Frame,
CommandButton, TabStrip, MultiPage, ScrollBar,
SpinButton, Image

• Events:
Change, Click, DblClick, Enter, Exit, Initialize,
KeyPress, SpinDown, and many more

• In editor for user form code sheet:
• Left drop-down list: control objects on this form
• Right drop-down list: events on that object  

Reference
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Callback Mechanisms

Pass object on which to call methodJava

Pass name of function as stringPHP

WithEvent / RaiseEvent statementsVBA class

Pass anonymous function (lambda)Perl, Python,
JavaScript

Pass code blockSmallTalk
Pass object on which to call “()” operatorC++
Pass function pointerC, C++

Subroutine in form with mangled nameVBA form

Concepts
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Events on Classes

• In event source class idsrc:
– Public Event idevent(arg*)
– RaiseEvent idevent(expr*)

• In event sink module:
– WithEvents idhandler As idsrc

– Sub idhandler_idevent(arg*) … End Sub

VBA
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Reusing Dialog Boxes

• Don’t write “open file” dialog from scratch!
• Application.Dialogs(id).Show

– E.g., id = xlDialogOptionsGeneral
– To find others: Help→Visual Basic→Search “build-

in dialog argument”
• Display instead of Show prevents handlers

– Return value: -2=Close, -1=OK, 0=Cancel,
>0 other command buttons

– Retrieve user input from controls with .Value

VBA
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How to Learn a Language

I. Use peers & gurus
II. Install tools
III. Read tutorial
IV. Find language & library reference
V. Read example programs
VI. Write example programs:

I/O, types, control flow, libraries
VII. Understand error messages
VIII. Practice

Soap-box
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Common VBA Mistakes
VBA

Common causeMessageError

Parentheses around
arguments, missing “Call”

Expected: =Compile
error

Missing space before “_”
at end of line

Invalid characterCompile
error

Missing “Set” before
object assignment

Object variable or With
block variable not set

Runtime
error ‘91’

And many more …
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Suggestions for VBA Practice
• hw02 gets you points, but you may

want to do more at your own leisure
• Powerpoint

– Center shape on slide
– Draw object model
– Plot a polynomial

• Excel
– Create graph, set fonts and grid preferences
– Generate email from name+title+address sheet

Soap-box
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Last Slide
• First homework due tomorrow at 4pm
• Quiz at end of next lecture at 7:30pm
• Please subscribe to class mailing list

Administrative

• Today’s lecture
– Putting the V and

the A in VBA
– Embedded scripts
– Properties
– Call-backs

• Next lecture
– Associative

arrays
– Regular

expressions
– Basics of Perl


